What do I have to do to receive post-EOS Office 2010 micropatches?

Mitja Kolsek -

To receive our post-End-of-Support Office 2010 micropatches, you have to:

  1. Have your Office 2010 installation updated with all available updates up to including January 2021 (currently latest updates). These currently include the following versions of essential files:
    WWLIB.DLL - 14.0.7264.5000
    WINWORD.EXE - 14.0.7264.5000
    EXCEL.EXE - 14.0.7264.5000
    GRAPH.EXE- 14.0.7264.5000
    OUTLOOK.EXE- 14.0.7261.5000
    MSACCESS.EXE - 14.0.7256.5000
    VISIO.EXE - 14.0.7248.5000
    POWERPNT.EXE - 14.0.7162.5000
  2. Install 0patch Agent on each computer running Office 2010 you want to protect with 0patch, and register these agents with your 0patch account. (Use silent installation with auto-registration for larger deployments.)
  3. Have a suitable number of 0patch PRO or 0patch Enterprise licenses in your 0patch account.
  4. Allow your 0patch-protected computers to connect to 0patch server (host dist.0patch.com, port 443) for periodic syncing in order for them to receive new micropatches and in order for you to remotely manage them (included in the Enterprise license).

 

Additional explanation on updates you need to have applied

To clarify this requirement, we must explain how our micropatches work: each micropatch we issue is applicable to a specific executable module (usually EXE or DLL), based on that module's cryptographic hash. If we want to micropatch the same vulnerability on two versions of EXCEL.EXE, for example, we need to make two micropatches (i.e., port the micropatch from the one that we patch first, to the other). While such porting is often trivial (but not always), each executable module on any Windows system comes in many versions, with most Windows Updates changing dozens to potentially hundreds of executable modules. To cut down on porting, and more importantly, to minimize the risk of our users not having the correct version of modules we're patching, we want them to have (ideally) identical copies of Office 2010. That is why we decided on our above requirement to "Apply all available Office 2010 updates up to including January 2021". We think this gives us the best chance of unifying all users' Office 2010 installations on a common baseline. Not installing some of the Office updates might result in some executable modules not being of the correct version, and micropatches for such modules would then not get applied. (Moreover, users would not even know they could have been applied but weren't due to improper version.) 

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.